Cong Router Cisco

Lab 4: Introducción a la configuración de routers CISCO con IOS José Mª Barceló Ordinas 1. Routers CISCO: IOS IOS 1.1. Introducción  En estos apuntes se explican conceptos básicos de la configuración de routers con sistema operativo IOS (“Internetworking Operating System”) del fabricante de routers Cisco Systems. 1.2. Estructura de un router  Un router IP es un computador especializado en conmutar datagramas IP. Dependiendo de las prestaciones que deba ofrecer, su estructura interna es más o menos compleja y especializada, pero para los modelos de gama baja, podemos pensar en una estructura similar a la de un PC: CPU, memoria, buses e interfaces de red. Para el almacenamiento de datos es habitual utilizar memoria ROM, memoria flash y memoria RAM y RAM no volátil (NVRAM): o o o o RAM: código, tablas de encaminamiento, buffers, cache ARP, etc. NVRAM (no volátil): fichero de configuración “startup-config”. Flash (no volátil): Imagen del IOS ROM (no volátil): parte de imagen IOS, código bootstrap. CPU RAM interface ROM interface NVRAM Flash Los sistemas operativos de los routers comerciales están especialmente diseñados para facilitar las tareas de conmutación de paquetes, la ejecución de algoritmos de encaminamiento, configuración de interfaces, etc. Un ejemplo de este tipo de sistemas operativos es el IOS. El IOS tiene una arquitectura simple y normalmente ocupa un espacio de memoria reducido. Cuando encendemos un router, se ejectua un programa de bootstrap cargado en la ROM que testea el sistema y carga en la RAM una imagen del IOS, normalmente desde la memoria flash. Configuraremos el router utilizando un interface de comandos en línea (CLI). Normalmente se hace a través de una conexión por la línea serie conectada al puerto CONSOLE del router, usando por ejemplo la aplicación HYPERTERMINAL en Windows, MiniCOM en Linux, etc. Los parámetros necesarios para conectarse son los siguientes: Baud Rate 9600 bps, 8 bits/carácter, 1 bits de Stop, No paridad y No control de flujo Hardware. La configuración activa del router se encuentra en un fichero llamado running-config. Si apagamos el router, dicha configuración se perdería y no estaría presente al volver a acttivar el router. Podemos guardar dicha configuración en un archivo de configuración ( startup-config) que normalmente se graba en una memoria NVRAM. Al arrancar el router, la configuración que se activa es la guardada en el archivo startup-config. También podemos configurar el router accediendo por telnet o utilizar un interfaz web para configurar el router. Asimismo tanto la imagen del IOS como el archivo de configuración se pueden obtener de un servidor de tftp. 1 Lab 4: Introducción a la configuración de routers CISCO con IOS José Mª Barceló Ordinas 1.3. Modos de configuración  Los router con IOS disponen de un conjunto de modos llamados de configuración que permiten la visualización y configuración del router. Los modos de configuración son los siguientes: o o o o o o Modo BOOT o ROM monitor: monitor : se usa en casos de emergencias (prompt típicamente rmon) como puede ser la recuperación de un password, de un registro de configuración, etc Modo de SETUP: SETUP: permite una configuración por menu sencilla y básica del router Modo USER EXEC: EXEC : es el modo de visualización sin privilegios (prompt R>) Modo PRIVILEGED EXEC: EXEC: modo de visualización con privilegios (prompt R#) Modo de Configuración Global o CONFIGURE : permite configurar aspectos sencillos del router como pueden ser la configuración del nombre del router, passwords, etc (prompt R(config)#) Modo de configuración específicos: específicos: permiten configurar protocolos, interfaces o en general aspectos más complejos del router (prompt R(config-if)#, R(config-route)#, R(config-line)#, etc) Al arrancar el router podemos pasar al modo SETUP, que permite dar una primera configuración al router cuando éste carece de una configuración preestablecida, o bien pasar al modo USER EXEC, cuando el router sí dispone de una configuración preestablecida. En modo USER EXEC podemos consultar aspectos básicos de la configuración del router 1. Para consultar aspectos más críticos de la configuración del router debemos pasar a modo PRIVILEGED EXEC. Para pasar de modo USER EXEC a modo PRIVILEGED EXEC es necesario usar un password (que se conoce como “enable secret password ” que se puede establecer desde el modo CONFIGURE ejecutando enable secret ) Desde los modos USER EXEC y PRIVILEGED EXEC no podemos modificar la configuración del router. Para hacerlo debemos pasar del modo PRIVILEGED EXEC al modo de configuracion general (CONFIGURE). Desde allí podemos configurar aspectos generales del funcionamiento del router o pasar a modos de configuración específicos de cada interfaz, algoritmo de encaminamiento, etc. Cuando estamos en modo USER EXEC el prompt que nos muestra el router es “ >”. Cuando estamos en PRIVILEGED EXEC el prompt es “ #” y en el modo de configuración global el prompt es (config)#. Router> Router> enable Router# config terminal Router(config)# enable secret PASSW Router(config)# exit Router# disable Router> enable pass: ****** (PASSW) Router# En la figura se muestran los diferentes modos de configuración junto con los principales comandos necesarios para cambiar de un modo a otro. Como ya hemos mencionado, los cambios de configuración que se realicen en el modo de configuración global o específico se guardan sobre un archivo de configuración residente en la RAM del router llamado “running-config”. Este fichero puede ser visualizado desde el modo de configuración privilegiado con el comando “show running-config”. Si el router se apagase, estos cambios se perderían al estar almacenados en RAM. Para que no se pierdan y pasen a estar permanentemente guardados en una memoria 1 Con el commando ? podemos obtener un listado de los comandos que se pueden ejecutar en cada modo. 2 Lab 4: Introducción a la configuración de routers CISCO con IOS José Mª Barceló Ordinas NVRAM hay que copiar el archivo “ running-config” (RAM) en el archivo “ startup-config” (NVRAM). Ello se puede hacer desde el modo PRIVILEGED EXEC con el comando “ copy runningconfig startup-config ”. USER EXEC enable disable PRIV. EXEC configure terminal ^z exit CONFIGURE interface eth0 exit CONF. IFACE. 1.4. Consulta del estado (comandos show)  Podemos consultar el estado de un router mediante los comandos show. Dependiendo del tipo de información que queremos consultar, el comando es ejecutable desde modo USER EXEC o bien necesitamos los privilegios del modo PRIVILEGED EXEC. Por ejemplo: show running-config muestra el fichero de configuración que está activo en el router show startup-config muestra el fichero de configuración que está grabado en la NVRAM show ip muestra los parámetros asociado a la configuración del protocolo IP. Por ejemplo, la tabla de encaminamiento IP se consulta con show ip route show interface eth0 muestra los parámetros asociados al interface Ethernet eth0 La tabla de encaminamiento es una información que no se considera privilegiada y que puede ser consultada desde el modo usuario USER EXEC. Sin embargo, el contenido de los ficheros de configuración si que se consideran privilegiados y sólo pueden ser visualizados desde el modo PRIVILEGED EXEC. 1.5. Configuración de los interfaces  Desde el modo de configuración podemos pasar a configurar los interfaces. Por ejemplo, para configurar un interface ethernet podemos hacer: Router# configure terminal Router(config)# interface eth0 Router(config-if)# ip address @IP MASK Router(config-if)# no shutdown Router(config-if)# exit Router# 3 Lab 4: Introducción a la configuración de routers CISCO con IOS José Mª Barceló Ordinas El commando “ no shutdown” es necesario para activar la interfaz. Por defecto, al arrancar el router todos los interfaces están desactivados. El comando “shutdown” en su defecto desactivaría administrativamente una interfaz. Las interfaces serie están diseñadas para que en la situación más normal se conecten a una operadora de telecomunicaciones a través de un DCE (e.g.; un MODEM o una Terminación de Red, TR). El DCE es el que normalmente da reloj y por tanto fija la velocidad de modulación y por consiguiente de transmisión. Si se conectan dos puertos serie de router (DTE-DTE) hay que usar un cable cruzado. Además uno de los dos puertos tiene que actuar como DCE dando reloj. En principio desde el punto de vista de router cualquiera de los dos puede actuar de DCE, así que lo importante es que conector del cable es el que marca que puerto es DCE. 1.6. Interficies serie  Una vez que sabemos que puerto es el que actúa de DCE, tiene que dar reloj. Está opción la tenemos que activar vía IOS con el comando “clockrate Bw”, donde Bw son los bps a los que queremos que trabaje la línea. En el puerto DTE no debemos activar este comando. En el siguiente ejemplo el Router-A es el actúa como DCE fijando una velocidad de transmisión de 56 Kbps y el Router-B es el que actúa como DTE. Router-A# configure terminal Router-A(config)# interface s0 Router-A(config-if)# ip address @IP MASK Router-A(config-if)# clockrate 56000 Router-A(config-if)# no shutdown Router-A(config-if)# exit Router-B# Router-B# configure terminal Router-B(config)# interface s0 Router-B(config-if)# ip address @IP MASK Router-B(config-if)# no shutdown Router-B(config-if)# exit Router-B# Las interfaces serie en los routers CISCO usan por defecto encapsulamiento HDLC (High Data-link Level Control) es un protocolo estandard, pero cuidado, CISCO usa una versión propietaria para sus enlaces WAN (sólo compatible con dispositivos CISCO). HDLC (Standard): (Standard) : HDLC (Propietary): (Propietary) : flag + address + control + data + FCS + flag flag + address + control + Propietary + data + FCS + flag R(config-if)# encapsulation hdlc à CISCO HDLC PPP (Point-to-Point Protocol): estándar del IETF, típicamente usado sobre interfaces físicas del tipo líneas asíncronas, ISDN y líneas síncronas. Permite autentificación (PAP o CHAP) y compresión (dos protocolos de compresión: Stacker y Predictor). PPP pasa por las siguientes fases: q q q Fase de establecimiento del enlace: negociación de los parámetros de nivel 2 (Magic Number, compresión de cabeceras, ...) Fase de autentificación: uso de PAP o CHAP Fase de configuración del protocolo de nivel de red: se negocian los parámetros de nivel de red (e.g.; la dirección IP) Cada router debe tener un nombre que se usará como username para autentificar. 4 Lab 4: Introducción a la configuración de routers CISCO con IOS José Mª Barceló Ordinas R(config)# hostname NAME R(config)# username NAME password PASSWORD  Donde NAME es el hostname del router remoto  El password debe ser el mismo en ambos routers  El password no se guarda encriptado, usar el siguiente comando para encriptar  R(config)# interface s0 R(config-if)# service password-encryption R(config-if)# encapsulation ppp R(config-if)# ppp authentication {chap | chap pap | pap chap | pap} R(config-if)# exit R(config)# exit R# show interface R# debug ppp authentication Otros parámetros de debugueo son (usa “no debug ppp ....” para desactivar el debug): debug ppp {packet | negotiation | error | authentication | compression | cbcp} donde: o o o o Packet: lista los paquetes PPP enviados y recibidos de datos Negotiation: lista los paquetes enviados y recibidos durante la negociación Authentication: lista los paquetes enviados y recibidos durante la autentificación Error: lista paquetes PPP con errores en la negociación Ejemplo: RA hostname R A username R B password pepe encapsulation ppp ppp authentication pap RB hostname R B username R A password pepe encapsulation ppp ppp authentication pap 1.7. Encaminamiento estático  A continuación vemos un ejemplo de configuración del encaminamiento estático usando el comando “ip route”. Router(config)# ip route @IPnet MASK @IPgw La primera dirección es la dirección de red destino. A continuación escribimos la máscara asociada a esa red. La tercera dirección correponde a la del interfaz del router por donde se establece la ruta (gateway por defecto). 1.8. Ejemplo de un archivo de configuración running-config. Este ejemplo muestra el archivo running-config para un router 2501, con dos interfaces ethernet y una interfaz serie, tiene activado RIPv1 en tres interfaces: Router# show running-config version 12.0 hostname router 5 Lab 4: Introducción a la configuración de routers CISCO con IOS José Mª Barceló Ordinas ! enable secret 5 $1$82gU$mleh/b6yIsfaX1NtRtzg $1$82gU$mleh/b6yIsfaX1NtRtzgm1 m1 enable password pepe ! interface Ethernet0 ip address 219.17.100.1 255.255.255.0 interface Serial0 ip address 199.6.13.1 255.255.255.0 clockrate 56000 ! interface Serial1 ip address 201.100.11.2 255.255.255.0 ! router rip network 199.6.13.0 network 201.100.11.0 network 219.17.100.0 ! no ip classless line con 0 password std line aux 0 password std line vty 0 4 password std login end 2. Sesión de Laboratorio A continuación vamos a configurar un router CISCO con las siguientes funcionalidades: o o o o Interfaces del router: asignar direcciones IP a cada una de las interfaces Routing estático Interfaz serie con protocolo PPP Debugging del protocolo PPP 2.1. Configuración del laboratorio  El profesor de la asignatura asignará un router CISCO a cada grupo de estudiantes. La topología genérica del laboratorio será la siguiente: RE D G T5 Consola RE D F RD RE D E RC Consola T4 RE D D T1 RE D A RA RB RE D B Consola Consola RE D C T3 6 Lab 4: Introducción a la configuración de routers CISCO con IOS José Mª Barceló Ordinas Numeramos las redes de la siguiente manera: o o o o REDA: 192.176.1.0/24 con @IP para la interficie del router 192.176.1.1/24 y @IP en el rango 192.176.1.5/24, 192.176.1.6/24, 192.176.1.7/24, ... a los PCs que queramos conectar a esta red REDB: 192.176.2.0/24 con @IP para la interficie del router 192.176.2.1/24 y @IP en el rango 192.176.2.5/24, 192.176.2.6/24, 192.176.2.7/24, ... a los PCs que queramos conectar a esta red REDC: 192.176.3.0/24 con @IP para la interficie del router 192.176.3.1/24 y @IP en el rango 192.176.3.5/24, 192.176.3.6/24, 192.176.3.7/24, ... a los PCs que queramos conectar a esta red .......... En general una red es de clase C con prefijo 192.176.X.0/24 con X=1, 2, 3, .... Los hosts o interfaces de cada red se numeran con respecto a la red a la que pertenece cada interfaz. Las direcciones IP más bajas (e.g.; hasta la X.10) se usan para interfaces de router y las más altas (a partir de la X.10) para interfaces de hosts. Las redes que se conectan a un host son Ethernet, mientras que las que conectan router con router son serie. Esta topología es genérica y puede variar en función de la cantidad de routers de que se dispongan. El profesor de la asignatura clarificará durante la sesión de laboratorio cual es la topología definitiva. 1. Configurar las interfaces de cada router con la dirección IP correspondiente. correspondient e. Por ejemplo un router con interfaces en las redes 192.176.1.0/24 y 192.176.2.0/24: Router> enable Router# configure terminal Router(config)# interface eth0/0 Router(config-if)# ip address 192.176.1.1 255.255.255.0 Router(config-if)# no shutdown Router(config-if)# exit Router(config)# interface eth0/1 Router(config-if)# ip address 192.176.2.1 255.255.255.0 Router(config-if)# no shutdown Router(config-if)# exit Router(config)# exit Router# 2. Configurar las interfaces de los hosts conectados con Ethernet y configurar como router por defecto la interfaz del router correspondiente. Comprobar que el host tiene conectividad con el router mediante el comando ping y ver el formato de la tabla de encaminamiento del host. 3. Ver el formato de la tabla de encaminamiento del router con el comando “show ip route” y comprobar que tienes conectividad con los routers vecinos y con el host de la red a la cual está directamente conectado. 4. Observar que desde un host sólo se tiene conectividad con cualquier interfaz del rotuer a la cual está directamente conectado. Explicar porqué. 5. Usar el comando “ip route” en cada router para tener conectividad con cualquier subred de la red establecida. 6. Ver el formato de la tabla de encaminamiento del router con el comando “show ip route” y comprobar que tienes conectividad con los todas las subredes de la red. 7 Lab 4: Introducción a la configuración de routers CISCO con IOS José Mª Barceló Ordinas 7. El profesor propondrá que una de las subredes cambie su dirección de red (y por consiguiente las direcciones de las interfaces asociadas a esa red). Observar como la tabla de encaminamiento sigue manteniendo la subred original y la nueva subred no es actualizada si no se modifica manualmente en todos los routers. 8. Comprobar con el comando “show interfaces” el tipo de encapsulamiento de las interfaces serie 9. Habilitar PPP en los enlaces serie y debuguear el establecimiento de la conexión y el proceso de autentificación con el comando “debug ppp ....” o o o o Comprobar con el comando “show interfaces” el tipo de encapsulamiento de las interfaces serie. Probar con distintas opciones de autentificación (PAP, CHAP, PAP y CHAP) Probar a tener distintos protocolos de autentificación en cada extremo. Probar con distintos passwords en cada extremo de la conexión serie 8
View more...
   EMBED

Share

Preview only show first 6 pages with water mark for full document please download

Transcript

Lab 4: Introducción a la configuración de routers CISCO con IOS

José Mª Barceló Ordinas

1. Routers CISCO: IOS

1.1. Introducción
En estos apuntes se explican conceptos básicos de la configuración de routers con sistema operativo IOS
(“Internetworking Operating System”) del fabricante de routers Cisco Systems.

1.2. Estructura de un router
Un router IP es un computador especializado en conmutar datagramas IP. Dependiendo de las prestaciones
que deba ofrecer, su estructura interna es más o menos compleja y especializada, pero para los modelos de
gama baja, podemos pensar en una estructura similar a la de un PC: CPU, memoria, buses e interfaces de
red. Para el almacenamiento de datos es habitual utilizar memoria ROM, memoria flash y memoria RAM y
RAM no volátil (NVRAM):

o RAM: código, tablas de encaminamiento, buffers, cache ARP, etc.
o NVRAM (no volátil): fichero de configuración “startup-config”.
o Flash (no volátil): Imagen del IOS
o ROM (no volátil): parte de imagen IOS, código bootstrap.

interface interface
CPU

RAM ROM NVRAM Flash

Los sistemas operativos de los routers comerciales están especialmente diseñados para facilitar las tareas de
conmutación de paquetes, la ejecución de algoritmos de encaminamiento, configuración de interfaces, etc.
Un ejemplo de este tipo de sistemas operativos es el IOS. El IOS tiene una arquitectura simple y
normalmente ocupa un espacio de memoria reducido. Cuando encendemos un router, se ejectua un
programa de bootstrap cargado en la ROM que testea el sistema y carga en la RAM una imagen del IOS,
normalmente desde la memoria flash.

Configuraremos el router utilizando un interface de comandos en línea (CLI). Normalmente se hace a
través de una conexión por la línea serie conectada al puerto CONSOLE del router, usando por ejemplo la
aplicación HYPERTERMINAL en Windows, MiniCOM en Linux, etc. Los parámetros necesarios para
conectarse son los siguientes: Baud Rate 9600 bps, 8 bits/carácter, 1 bits de Stop, No paridad y No control
de flujo Hardware.

La configuración activa del router se encuentra en un fichero llamado running-config. Si apagamos el
router, dicha configuración se perdería y no estaría presente al volver a acttivar el router. Podemos guardar
dicha configuración en un archivo de configuración (startup-config) que normalmente se graba en
una memoria NVRAM. Al arrancar el router, la configuración que se activa es la guardada en el archivo
startup-config.

También podemos configurar el router accediendo por telnet o utilizar un interfaz web para configurar el
router. Asimismo tanto la imagen del IOS como el archivo de configuración se pueden obtener de un
servidor de tftp.

1
Lab 4: Introducción a la configuración de routers CISCO con IOS
José Mª Barceló Ordinas

1.3. Modos de configuración
Los router con IOS disponen de un conjunto de modos llamados de configuración que permiten la
visualización y configuración del router. Los modos de configuración son los siguientes:

o Modo BOOT o ROM monitor: se usa en casos de emergencias (prompt típicamente rmon)
como puede ser la recuperación de un password, de un registro de configuración, etc
o Modo de SETUP: permite una configuración por menu sencilla y básica del router
o Modo USER EXEC: es el modo de visualización sin privilegios (prompt R>)
o Modo PRIVILEGED EXEC: modo de visualización con privilegios (prompt R#)
o Modo de Configuración Global o CONFIGURE: permite configurar aspectos sencillos del
router como pueden ser la configuración del nombre del router, passwords, etc (prompt
R(config)#)
o Modo de configuración específicos: permiten configurar protocolos, interfaces o en general
aspectos más complejos del router (prompt R(config-if)#, R(config-route)#,
R(config-line)#, etc)

Al arrancar el router podemos pasar al modo SETUP, que permite dar una primera configuración al router
cuando éste carece de una configuración preestablecida, o bien pasar al modo USER EXEC, cuando el
router sí dispone de una configuración preestablecida.

En modo USER EXEC podemos consultar aspectos básicos de la configuración del router1. Para consultar
aspectos más críticos de la configuración del router debemos pasar a modo PRIVILEGED EXEC. Para
pasar de modo USER EXEC a modo PRIVILEGED EXEC es necesario usar un password (que se conoce
como “enable secret password” que se puede establecer desde el modo CONFIGURE ejecutando enable
secret <passwd>)

Desde los modos USER EXEC y PRIVILEGED EXEC no podemos modificar la configuración del router.
Para hacerlo debemos pasar del modo PRIVILEGED EXEC al modo de configuracion general
(CONFIGURE). Desde allí podemos configurar aspectos generales del funcionamiento del router o pasar a
modos de configuración específicos de cada interfaz, algoritmo de encaminamiento, etc.

Cuando estamos en modo USER EXEC el prompt que nos muestra el router es “>”. Cuando estamos en
PRIVILEGED EXEC el prompt es “#” y en el modo de configuración global el prompt es (config)#.

Router>
Router> enable
Router# config terminal
Router(config)# enable secret PASSW
Router(config)# exit
Router# disable
Router> enable
pass: ****** (PASSW)
Router#

En la figura se muestran los diferentes modos de configuración junto con los principales comandos
necesarios para cambiar de un modo a otro.

Como ya hemos mencionado, los cambios de configuración que se realicen en el modo de configuración
global o específico se guardan sobre un archivo de configuración residente en la RAM del router llamado
“running-config”. Este fichero puede ser visualizado desde el modo de configuración privilegiado
con el comando “show running-config”. Si el router se apagase, estos cambios se perderían al estar
almacenados en RAM. Para que no se pierdan y pasen a estar permanentemente guardados en una memoria

1
Con el commando ? podemos obtener un listado de los comandos que se pueden ejecutar en cada modo.

2
Lab 4: Introducción a la configuración de routers CISCO con IOS
José Mª Barceló Ordinas

NVRAM hay que copiar el archivo “running-config” (RAM) en el archivo “startup-config”
(NVRAM). Ello se puede hacer desde el modo PRIVILEGED EXEC con el comando “copy running-
config startup-config”.

USER EXEC

enable disable

PRIV. EXEC
configure terminal
exit
^z CONFIGURE

interface eth0
exit

CONF. IFACE.

1.4. Consulta del estado (comandos show)
Podemos consultar el estado de un router mediante los comandos show. Dependiendo del tipo de
información que queremos consultar, el comando es ejecutable desde modo USER EXEC o bien
necesitamos los privilegios del modo PRIVILEGED EXEC. Por ejemplo:

show running-config muestra el fichero de configuración que está activo en el router

show startup-config muestra el fichero de configuración que está grabado en la NVRAM

show ip <parameter> muestra los parámetros asociado a la configuración del protocolo IP. Por
ejemplo, la tabla de encaminamiento IP se consulta con show ip route

show interface eth0 muestra los parámetros asociados al interface Ethernet eth0

La tabla de encaminamiento es una información que no se considera privilegiada y que puede ser
consultada desde el modo usuario USER EXEC. Sin embargo, el contenido de los ficheros de
configuración si que se consideran privilegiados y sólo pueden ser visualizados desde el modo
PRIVILEGED EXEC.

1.5. Configuración de los interfaces
Desde el modo de configuración podemos pasar a configurar los interfaces. Por ejemplo, para configurar un
interface ethernet podemos hacer:

Router# configure terminal
Router(config)# interface eth0
Router(config-if)# ip address @IP MASK
Router(config-if)# no shutdown
Router(config-if)# exit
Router#

3
Lab 4: Introducción a la configuración de routers CISCO con IOS
José Mª Barceló Ordinas

El commando “no shutdown” es necesario para activar la interfaz. Por defecto, al arrancar el router
todos los interfaces están desactivados. El comando “shutdown” en su defecto desactivaría
administrativamente una interfaz.

Las interfaces serie están diseñadas para que en la situación más normal se conecten a una operadora de
telecomunicaciones a través de un DCE (e.g.; un MODEM o una Terminación de Red, TR). El DCE es el
que normalmente da reloj y por tanto fija la velocidad de modulación y por consiguiente de transmisión.

Si se conectan dos puertos serie de router (DTE-DTE) hay que usar un cable cruzado. Además uno de los
dos puertos tiene que actuar como DCE dando reloj. En principio desde el punto de vista de router
cualquiera de los dos puede actuar de DCE, así que lo importante es que conector del cable es el que marca
que puerto es DCE.

1.6. Interficies serie
Una vez que sabemos que puerto es el que actúa de DCE, tiene que dar reloj. Está opción la tenemos que
activar vía IOS con el comando “clockrate Bw”, donde Bw son los bps a los que queremos que
trabaje la línea. En el puerto DTE no debemos activar este comando. En el siguiente ejemplo el Router-A es
el actúa como DCE fijando una velocidad de transmisión de 56 Kbps y el Router-B es el que actúa como
DTE.

Router-A# configure terminal
Router-A(config)# interface s0
Router-A(config-if)# ip address @IP MASK
Router-A(config-if)# clockrate 56000
Router-A(config-if)# no shutdown
Router-A(config-if)# exit
Router-B#

Router-B# configure terminal
Router-B(config)# interface s0
Router-B(config-if)# ip address @IP MASK
Router-B(config-if)# no shutdown
Router-B(config-if)# exit
Router-B#

Las interfaces serie en los routers CISCO usan por defecto encapsulamiento HDLC (High Data-link Level
Control) es un protocolo estandard, pero cuidado, CISCO usa una versión propietaria para sus enlaces
WAN (sólo compatible con dispositivos CISCO).

HDLC (Standard): flag + address + control + data + FCS + flag
HDLC (Propietary): flag + address + control + Propietary + data + FCS + flag

R(config-if)# encapsulation hdlc à CISCO HDLC

PPP (Point-to-Point Protocol): estándar del IETF, típicamente usado sobre interfaces físicas del tipo
líneas asíncronas, ISDN y líneas síncronas. Permite autentificación (PAP o CHAP) y compresión (dos
protocolos de compresión: Stacker y Predictor). PPP pasa por las siguientes fases:

q Fase de establecimiento del enlace: negociación de los parámetros de nivel 2 (Magic Number,
compresión de cabeceras, ...)
q Fase de autentificación: uso de PAP o CHAP
q Fase de configuración del protocolo de nivel de red: se negocian los parámetros de nivel de red
(e.g.; la dirección IP)

Cada router debe tener un nombre que se usará como username para autentificar.

4
Lab 4: Introducción a la configuración de routers CISCO con IOS
José Mª Barceló Ordinas

R(config)# hostname NAME
R(config)# username NAME password PASSWORD
Donde NAME es el hostname del router remoto
El password debe ser el mismo en ambos routers
El password no se guarda encriptado, usar el siguiente comando para encriptar
R(config)# interface s0
R(config-if)# service password-encryption
R(config-if)# encapsulation ppp
R(config-if)# ppp authentication {chap | chap pap | pap chap | pap}
R(config-if)# exit
R(config)# exit
R# show interface
R# debug ppp authentication

Otros parámetros de debugueo son (usa “no debug ppp ....” para desactivar el debug):

debug ppp {packet | negotiation | error | authentication | compression | cbcp}
donde:

o Packet: lista los paquetes PPP enviados y recibidos de datos
o Negotiation: lista los paquetes enviados y recibidos durante la negociación
o Authentication: lista los paquetes enviados y recibidos durante la autentificación
o Error: lista paquetes PPP con errores en la negociación

Ejemplo:

RA RB

hostname R A hostname R B
username R B password pepe username R A password pepe
encapsulation ppp encapsulation ppp
ppp authentication pap ppp authentication pap

1.7. Encaminamiento estático
A continuación vemos un ejemplo de configuración del encaminamiento estático usando el comando “ip
route”.

Router(config)# ip route @IPnet MASK @IPgw

La primera dirección es la dirección de red destino. A continuación escribimos la máscara asociada a esa
red. La tercera dirección correponde a la del interfaz del router por donde se establece la ruta (gateway por
defecto).

1.8. Ejemplo de un archivo de configuración running-config.
Este ejemplo muestra el archivo running-config para un router 2501, con dos interfaces ethernet y una
interfaz serie, tiene activado RIPv1 en tres interfaces:

Router# show running-config
version 12.0
hostname router

5
Lab 4: Introducción a la configuración de routers CISCO con IOS
José Mª Barceló Ordinas

!
enable secret 5 $1$82gU$mleh/b6yIsfaX1NtRtzgm1
enable password pepe
!
interface Ethernet0
ip address 219.17.100.1 255.255.255.0

interface Serial0
ip address 199.6.13.1 255.255.255.0
clockrate 56000
!
interface Serial1
ip address 201.100.11.2 255.255.255.0
!
router rip
network 199.6.13.0
network 201.100.11.0
network 219.17.100.0
!
no ip classless
line con 0
password std
line aux 0
password std
line vty 0 4
password std
login
end

2. Sesión de Laboratorio
A continuación vamos a configurar un router CISCO con las siguientes funcionalidades:

o Interfaces del router: asignar direcciones IP a cada una de las interfaces
o Routing estático
o Interfaz serie con protocolo PPP
o Debugging del protocolo PPP

2.1. Configuración del laboratorio
El profesor de la asignatura asignará un router CISCO a cada grupo de estudiantes. La topología genérica
del laboratorio será la siguiente:

RED G RED F RED E

T5 RD RC T4
Consola Consola
RED D
T1 RA
RED A RB

RED B

Consola RED C
Consola
T3

6
Lab 4: Introducción a la configuración de routers CISCO con IOS
José Mª Barceló Ordinas

Numeramos las redes de la siguiente manera:

o REDA: 192.176.1.0/24 con @IP para la interficie del router 192.176.1.1/24 y @IP en el rango
192.176.1.5/24, 192.176.1.6/24, 192.176.1.7/24, ... a los PCs que queramos conectar a esta red
o REDB: 192.176.2.0/24 con @IP para la interficie del router 192.176.2.1/24 y @IP en el rango
192.176.2.5/24, 192.176.2.6/24, 192.176.2.7/24, ... a los PCs que queramos conectar a esta red
o REDC: 192.176.3.0/24 con @IP para la interficie del router 192.176.3.1/24 y @IP en el rango
192.176.3.5/24, 192.176.3.6/24, 192.176.3.7/24, ... a los PCs que queramos conectar a esta red
o ..........

En general una red es de clase C con prefijo 192.176.X.0/24 con X=1, 2, 3, .... Los hosts o interfaces de
cada red se numeran con respecto a la red a la que pertenece cada interfaz. Las direcciones IP más bajas
(e.g.; hasta la X.10) se usan para interfaces de router y las más altas (a partir de la X.10) para interfaces de
hosts.

Las redes que se conectan a un host son Ethernet, mientras que las que conectan router con router son serie.
Esta topología es genérica y puede variar en función de la cantidad de routers de que se dispongan. El
profesor de la asignatura clarificará durante la sesión de laboratorio cual es la topología definitiva.

1. Configurar las interfaces de cada router con la dirección IP correspondiente. Por ejemplo un router
con interfaces en las redes 192.176.1.0/24 y 192.176.2.0/24:

Router> enable
Router# configure terminal
Router(config)# interface eth0/0
Router(config-if)# ip address 192.176.1.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface eth0/1
Router(config-if)# ip address 192.176.2.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# exit
Router#

2. Configurar las interfaces de los hosts conectados con Ethernet y configurar como router por
defecto la interfaz del router correspondiente. Comprobar que el host tiene conectividad con el
router mediante el comando ping y ver el formato de la tabla de encaminamiento del host.

3. Ver el formato de la tabla de encaminamiento del router con el comando “show ip route” y
comprobar que tienes conectividad con los routers vecinos y con el host de la red a la cual está
directamente conectado.

4. Observar que desde un host sólo se tiene conectividad con cualquier interfaz del rotuer a la cual
está directamente conectado. Explicar porqué.

5. Usar el comando “ip route” en cada router para tener conectividad con cualquier subred de la
red establecida.

6. Ver el formato de la tabla de encaminamiento del router con el comando “show ip route” y
comprobar que tienes conectividad con los todas las subredes de la red.

7
Lab 4: Introducción a la configuración de routers CISCO con IOS
José Mª Barceló Ordinas

7. El profesor propondrá que una de las subredes cambie su dirección de red (y por consiguiente las
direcciones de las interfaces asociadas a esa red). Observar como la tabla de encaminamiento sigue
manteniendo la subred original y la nueva subred no es actualizada si no se modifica manualmente
en todos los routers.

8. Comprobar con el comando “show interfaces” el tipo de encapsulamiento de las interfaces serie

9. Habilitar PPP en los enlaces serie y debuguear el establecimiento de la conexión y el proceso de
autentificación con el comando “debug ppp ....”

o Comprobar con el comando “show interfaces” el tipo de encapsulamiento de las
interfaces serie.
o Probar con distintas opciones de autentificación (PAP, CHAP, PAP y CHAP)
o Probar a tener distintos protocolos de autentificación en cada extremo.
o Probar con distintos passwords en cada extremo de la conexión serie

8